Get in touch
Back
Degraded

Update to the 3Connect Contact Landline Service

Started 25 Jul at 12:15pm IST, resolved 26 Jul at 08:00am IST.

status.wix.com/api/v2/components.json
Resolved

Update-Resolved

Posted 26 Jul at 08:00am IST.
Created

Services Affected
3 Connect - (01) 524 0113 please stay alert to this as may be some issues and cause difficulties trying to call us please contact us through email or via live chat on website until update is complete

Posted 25 Jul at 12:15pm IST.